PROPHET64 & MSSIAH Userforum




Official information and support forum for
MSSIAH and all PROPHET64 versions.



You are not logged in.

#1 2016-02-01 02:05:59

unexpectedbowtie
Bloody beginner
Registered: 2016-01-28
Posts: 3

MSSIAH Cart Mono Synth Problems - no sound output (diagnostics fine)

Hello!

I dug out my old C64 and MSSIAH cart combo and got it rigged up with an external monitor, with the intention to play it using the mono synth program. Everything is working great, and the diagnostic tests show that the SID chip is fine - loud sounds coming out in response. The one problem is that when I get into Mono Synth and set it up to be played with the C64 keyboard, there's no audio output.

Here's what I'm doing in Mono Synth:

1. Go to Settings and set the MIDI option to 'C64 keyboard'.
2. Set the Synth to MIDI mode so the screen goes blank.
3. Play the keys with different Patches loaded.

I can hear some sort of change in the audio output - in that there's a very very quiet click or whirr at different frequencies depending on the patch, but there's no other output. No big SID sound like I'm getting from the diagnostics.

Am I doing something stupid? Probably... It's hard to read the dials so it could be that I'm missing something really obvious, but I'd have expected some sort of more audible output with at least one of the default patches.

Help :'(

Offline

 

#2 2016-02-02 12:51:04

Headloc
Bomb Jack
From: North Wales, UK
Registered: 2007-03-24
Posts: 35
Website

Re: MSSIAH Cart Mono Synth Problems - no sound output (diagnostics fine)

Hi
My machine is in pieces right now but i'll probably be putting it together again later today. I'll test it out and let you know.


make it come out green...

Offline

 

#3 2016-02-02 12:52:11

unexpectedbowtie
Bloody beginner
Registered: 2016-01-28
Posts: 3

Re: MSSIAH Cart Mono Synth Problems - no sound output (diagnostics fine)

Hey! So I finally got it to work after messing around. Turns out that no matter what I did to the patches there was no sound, but if I loaded up the demo patches first, I could then manipulate them fine and get the expected audio out.

Thanks for the help!

Offline

 

#4 2016-02-02 13:11:07

Headloc
Bomb Jack
From: North Wales, UK
Registered: 2007-03-24
Posts: 35
Website

Re: MSSIAH Cart Mono Synth Problems - no sound output (diagnostics fine)

Cool!
Glad to see you got it working. Thanks for sharing your solution.


make it come out green...

Offline

 

#5 2016-02-02 13:35:02

unexpectedbowtie
Bloody beginner
Registered: 2016-01-28
Posts: 3

Re: MSSIAH Cart Mono Synth Problems - no sound output (diagnostics fine)

Next step... doubleSID! I've got the 6581 SID. Need to read up into whether I can double it up with one of the newer ones.

Offline

 

Board footer

Powered by
© Copyright 2002–2008